CVE-2009-2409

Priority
Medium
Description
The Network Security Services (NSS) library before 3.12.3, as used in
Firefox; GnuTLS before 2.6.4 and 2.7.4; OpenSSL 0.9.8 through 0.9.8k; and
other products support MD2 with X.509 certificates, which might allow
remote attackers to spoof certificates by using MD2 design flaws to
generate a hash collision in less than brute-force time. NOTE: the scope
of this issue is currently limited because the amount of computation
required is still large.
References
Bugs
Assigned-to
mdeslaur
Package
Upstream:released (6b17)
Ubuntu 8.04 LTS (Hardy Heron):released (6b18-1.8.2-4ubuntu1~8.04.1)
Ubuntu 10.04 LTS (Lucid Lynx):not-affected (6b17~pre2-0ubuntu3)
Ubuntu 11.04 (Natty Narwhal):not-affected (6b17~pre2-0ubuntu3)
Package
Upstream:needs-triage
Ubuntu 8.04 LTS (Hardy Heron):released (0.9.8g-4ubuntu3.8)
Ubuntu 10.04 LTS (Lucid Lynx):not-affected
Ubuntu 11.04 (Natty Narwhal):not-affected
Patches:
Upstream:http://marc.info/?l=openssl-cvs&m=124508133203041&w=2
Upstream:http://marc.info/?l=openssl-cvs&m=124704528713852&w=2
Package
Upstream:needs-triage
Ubuntu 8.04 LTS (Hardy Heron):DNE
Ubuntu 10.04 LTS (Lucid Lynx):not-affected
Ubuntu 11.04 (Natty Narwhal):not-affected
Package
Source: nss (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 8.04 LTS (Hardy Heron):released (3.12.3.1-0ubuntu0.8.04.1)
Ubuntu 10.04 LTS (Lucid Lynx):not-affected
Ubuntu 11.04 (Natty Narwhal):not-affected
Package
Upstream:needs-triage
Ubuntu 8.04 LTS (Hardy Heron):DNE
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 11.04 (Natty Narwhal):DNE
Package
Upstream:needs-triage
Ubuntu 8.04 LTS (Hardy Heron):released (2.0.4-1ubuntu2.5)
Ubuntu 10.04 LTS (Lucid Lynx):DNE
Ubuntu 11.04 (Natty Narwhal):DNE
More Information

Valid XHTML 1.0 Strict

Updated: 2012-06-01 15:19:57 UTC (commit 5347)