CVE-2009-1513

Priority
Low
Description
Buffer overflow in the PATinst function in src/load_pat.cpp in libmodplug
before 0.8.7 allows user-assisted remote attackers to cause a denial of
service and possibly execute arbitrary code via a long instrument name.
References
Bugs
Assigned-to
mdeslaur
Package
Upstream:released (0.8.7)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (1:0.8.7-1)
Patches:
Upstream:http://modplug-xmms.git.sourceforge.net/git/gitweb.cgi?p=modplug-xmms;a=commitdiff;h=c4ebb701be6ee9a296a44fdac5a20b7739ff0595
Package
Upstream:needs-triage
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (uses system libmodplug)
More Information

Valid XHTML 1.0 Strict

Updated: 2015-07-29 20:35:44 UTC (commit 9756)