CVE-2008-3655

Priority
Low
Description
Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71,
and 1.9 through r18423 does not properly restrict access to critical
variables and methods at various safe levels, which allows
context-dependent attackers to bypass intended access restrictions via (1)
untrace_var, (2) $PROGRAM_NAME, and (3) syslog at safe level 4, and (4)
insecure methods at safe levels 1 through 3.
References
Bugs
Assigned-to
jdstrand
Package
Upstream:released (1.8.7.72-1)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (1.8.7.72-1)
Package
Upstream:released (1.9.0.2-7)
Ubuntu 12.04 LTS (Precise Pangolin):DNE (pulled 2010-07-27)
More Information

Valid XHTML 1.0 Strict

Updated: 2015-07-29 20:33:18 UTC (commit 9756)