CVE-2008-2662

Priority
Medium
Description
Multiple integer overflows in the rb_str_buf_append function in Ruby 1.8.4
and earlier, 1.8.5 before 1.8.5-p231, 1.8.6 before 1.8.6-p230, 1.8.7 before
1.8.7-p22, and 1.9.0 before 1.9.0-2 allow context-dependent attackers to
execute arbitrary code or cause a denial of service via unknown vectors
that trigger memory corruption, a different issue than CVE-2008-2663,
CVE-2008-2664, and CVE-2008-2725. NOTE: as of 20080624, there has been
inconsistent usage of multiple CVE identifiers related to Ruby. This CVE
description should be regarded as authoritative, although it is likely to
change.
References
Assigned-to
jdstrand
Package
Upstream:released (1.8.7.22-1)
Ubuntu 8.04 LTS (Hardy Heron):released (1.8.6.111-2ubuntu1.1)
Ubuntu 10.04 LTS (Lucid Lynx):not-affected (1.8.7.22-1)
Ubuntu 11.04 (Natty Narwhal):not-affected (1.8.7.22-1)
Ubuntu 11.10 (Oneiric Ocelot):not-affected (1.8.7.22-1)
Ubuntu 12.04 LTS (Precise Pangolin):not-affected (1.8.7.22-1)
Package
Upstream:released (1.9.0.2-1)
Ubuntu 8.04 LTS (Hardy Heron):ignored (reached end-of-life)
Ubuntu 10.04 LTS (Lucid Lynx):released (1.9.0.2-1ubuntu1)
Ubuntu 11.04 (Natty Narwhal):DNE (pulled 2010-07-27)
Ubuntu 11.10 (Oneiric Ocelot):DNE (pulled 2010-07-27)
Ubuntu 12.04 LTS (Precise Pangolin):DNE (pulled 2010-07-27)
More Information

Valid XHTML 1.0 Strict

Updated: 2012-06-01 15:18:51 UTC (commit 5347)