CVE-2007-4662

Priority
Medium
Description
Buffer overflow in the php_openssl_make_REQ function in PHP before 5.2.4
has unknown impact and attack vectors.
References
Notes
kees> http://cvs.php.net/viewcvs.cgi/php-src/ext/openssl/openssl.c?r1=1.146&r2=1.147
kees> upstream is wrong: should be 199 not 200.
kees> 203-openssl_make_REQ-overflow.patch
Assigned-to
kees
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.2.4)
Ubuntu 8.04 LTS (Hardy Heron):not-affected (5.2.4-2ubuntu3)
More Information

Valid XHTML 1.0 Strict

Updated: 2012-06-01 15:18:11 UTC (commit 5347)